Aventail Connect 4.1.2.13 Hostname Remote Buffer Overflow Vulnerability



source: http://www.securityfocus.com/bid/23717/info


Aventail Connect is prone to a buffer-overflow vulnerability because the application fails to bounds-check user-supplied data before copying it into an insufficiently sized buffer.

An attacker may exploit this issue to execute arbitrary code within the context of the affected application. Failed exploit attempts wlll result in a denial of service.

This issue affects Aventail Connect 4.1.2.13; other versions may also be affected. 

ssh $(perl -e 'print 'a'x2200')