Apple Mac OS X 10.x - LZWDecodeVector (.tiff) Overflow



source: http://www.securityfocus.com/bid/17634/info


Apple Mac OS X is reported prone to multiple security vulnerabilities.

These issue affect Mac OS X and various applications including Safari, Preview, Finder, QuickTime, and BOMArchiveHelper. A remote attacker may exploit these issues to execute arbitrary code and/or trigger a denial-of-service condition.

Apple Mac OS X 10.4.6 and prior are reported vulnerable to these issues.

https://github.com/offensive-security/exploit-database-bin-sploits/raw/master/sploits/27714-1.html

https://github.com/offensive-security/exploit-database-bin-sploits/raw/master/sploits/27714-2.html

https://github.com/offensive-security/exploit-database-bin-sploits/raw/master/sploits/27714-3.tiff