National Science Foundation Squid Proxy 2.3 Internet Access Control Bypass Vulnerability



source: http://www.securityfocus.com/bid/10315/info


Squid proxy has been reported to be affected by an Internet access control bypass vulnerability. This issue is caused by a failure of the application to properly handle access controls when evaluating malformed URI requests.

This issue is reported to affect version 2.3.STABLE5 of the software, it is likely however that other versions are also affected.

This issue would allow users that are restricted from accessing Internet-based resources to access arbitrary web sites.

http://@@website_allowed.pt@restricted_internet_resource.html