Samba 2.2.x - 'call_trans2open' Remote Buffer Overflow Vulnerability (4)



source: http://www.securityfocus.com/bid/7294/info

   
A buffer overflow vulnerability has been reported for Samba. The problem occurs when copying user-supplied data into a static buffer. By passing excessive data to an affected Samba server, it may be possible for an anonymous user to corrupt sensitive locations in memory.
   
Successful exploitation of this issue could allow an attacker to execute arbitrary commands, with the privileges of the Samba process.
   
It should be noted that this vulnerability affects Samba 2.2.8 and earlier. Samba-TNG 0.3.1 and earlier are also affected. 

https://github.com/offensive-security/exploit-database-bin-sploits/raw/master/sploits/22471.tar.gz