Apple MacOS Internet Explorer 3/4/5 File Execution Vulnerability



source: http://www.securityfocus.com/bid/3935/info


A vulnerability has been discovered in MacOS systems running Internet Explorer 5.1 and earlier. MacOS X is not affected by this issue.

File URLs may be used by a malicious webmaster to execute programs on a web user's local system. The exact path to the location of the file must be known. This includes being able to anticipate the name of a particular user's hard drive.

This issue may be exploited to execute "Speakable Items" in MacOS 8 and 9.

This issue may also be exploitable through maliciously crafted HTML-enabled e-mail. 

<META HTTP-EQUIV="refresh" CONTENT="1; URL=file:///Macintosh%20HD/System%20Folder/Speakable%20Items/Put%20Computer%20To%20Sleep">