X-Chat 1.x CTCP Ping Arbitrary Remote IRC Command Execution Vulnerability



source: http://www.securityfocus.com/bid/3830/info


X-Chat is a graphical client for IRC. It requires the GTK+ toolkit, and is available for many Linux and Unix operating systems.

If a CTCP ping request includes escaped newline characters and additional IRC commands, these commands may be executed by the vulnerable client. It is possible to gain operator status in channels owned by the vulnerable user, or to use their identity to initiate social engineering attacks.

Although this vulnerability exists in recent versions of X-Chat, the option to expand characters has been disabled by default since version 1.4.3. 

cat 21210.exploit - | netcat server 6667 

https://github.com/offensive-security/exploit-database-bin-sploits/raw/master/sploits/21210.exploit