Linux Kernel 2.2 / 2.4 - Ptrace/Setuid Exec Local Root Vulnerability



source: http://www.securityfocus.com/bid/3447/info


Linux contains a vulnerability in it's exec() implementation that may allow for modification of setuid process memory via ptrace(). The vulnerability is due to the fact that it is possible for a traced process to exec() a setuid image if the tracing process is setuid.

Attackers can exploit this to elevate privileges.

Note: There are currently conflicting reports about the exploitability of this vulnerability.

https://github.com/offensive-security/exploit-database-bin-sploits/raw/master/sploits/21124.tgz