Linux Kernel 2.2 - ldd core Force Reboot Vulnerability



source: http://www.securityfocus.com/bid/344/info



Due to a rare and subtle bug in the 2.2.0 kernel, a linux machine can be forced to reboot by an unpriviliged local user. The reason for this is because of the invalid ELF core layout and the fact that munmap wipes out a vital page table entry.

Only kernel 2.2.0 is vulnerable to this.


Take any core file,

[user@box tmp]$ ldd core

[reboot]